apt updateの実行時に出力される python3のエラーについて(環境:Ubuntu 18.04.1 LTS)

$ sudo apt update

無視:8 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu bionic InRelease

エラー:11 http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu bionic Release
404 Not Found [IP: 91.189.95.83 80]

パッケージリストを読み込んでいます… 完了
E: リポジトリ http://ppa.launchpad.net/jonathonf/python-3.6/ubuntu bionic Release には Release ファイルがありません。
N: このようなリポジトリから更新を安全に行うことができないので、デフォルトでは更新が無効になっています。
N: リポジトリの作成とユーザ設定の詳細は、apt-secure(8) man ページを参照してください。


Ubuntu 18.04 (2018.8月時点)では、python3をPPAが対応していない。
このため、apt?-では対応できないため、当該エラーメッセージが出力される。
python3の動作自体には支障がない。
ということで、
当該エラーメッセージは、気にしない。

(参考1)ある特定のppaを追加したらアップデートを失敗します。
(参考2)Make on Ubuntu bionic 18.04 LTS fails, ppa or connection?

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です